jueves, 21 de noviembre de 2013

Instalación de Google-Chrome en Wheezy

Primero descargamos el paquete de Google Chrome, vamos a un terminal como root y colocamos lo siguiente:

Instalamos las librerias:
# aptitude install libcurl3 libxss1

GNU/Linux Debian de 32 bits (i386)
Para descargar la versión de 32 bits, ejecute en una terminal el siguiente comando:


$ wget -c https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb -O /tmp/google-chrome-stable_current_i386.deb

Para instalar el paquete recién descargado, ejecute el siguiente comando:
$ sudo dpkg -i /tmp/google-chrome-stable_current_i386.deb

GNU/Linux Debian de 64 bits (amd64)
Para descargar la versión de 64 bits, ejecute en una terminal el siguiente comando:


$ wget -c https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb -O /tmp/google-chrome-stable_current_amd64.deb

Para instalar el paquete recién descargado, ejecute el siguiente comando:
$ sudo dpkg -i /tmp/google-chrome-stable_current_amd64.deb

El resto del proceso es independiente de la arquitectura
Si no tiene previamente instalado el paquete "libcurl3", durante la instalación anterior se habrá mostrado una notificación en la consola indicando que ocurrieron errores al procesar. Para solucionarlo ejecute el siguiente comando:
$ sudo apt-get install -f

19 comentarios:

  1. Hola Kimberling por favor podrias decirme como corregir el error de ifupdown (etho) en la canaima de mi hijo de 8 años que no puede navega por wifi ni por cable, gracias de antemano ya que el niño tiene mas de un mes que no puede accesar y la verdad ya
    me tiene mas loco de lo que soy. Que Dios te bendiga

    ResponderEliminar
    Respuestas
    1. Hola Jesus como estas?? oye una pregunta que modelo es la canaima de tu hijo?? puedes ir al menu -> accesorios -> terminal -> entrar como root (super usuario) y colocar el comando lspci, lo que arroje el comando me lo puedes mandar para ver que firmware necesita.
      Puedes ver en el archivo /etc/network/interfaces si tiene esta configuración:

      # The loopback network interface
      auto lo
      iface lo inet loopback

      # The primary network interface
      allow-hotplug eth0
      iface eth0 inet dhcp

      Cualquier duda me avisa, Amen! :-)

      Eliminar
  2. Este comentario ha sido eliminado por el autor.

    ResponderEliminar
  3. Buenos días kimberli, cómo hago para establecer una red lan entre dos canaimitas a través de un switch? qué debo instalar, qué pasos debo seguir, pues ya las he conectado y no he logrado acceder a ninguna, instale el samba

    ResponderEliminar
    Respuestas
    1. Hola amigo como estas? Buenos días. Oye amigo debes colocar el switch del switch debes colocar los dos cables conectados a cada una de las canaimas, una vez q los cables estén conectados debes asignarle IP, una vez los equipos tengan IP asignada debes hacerle ping de una a otra para verificar que se vean en la misma red, luego de que ambas se vean se configuran los servicios de recursos compartidos como el samba para compartir carpeta, etc.
      COMO SE CONFIGURAN LAS IP???:
      vamos al menu de canaima -> Accesorio -> Terminal y entras como root (super usuario) y colocas esta linea:

      nano /etc/network/interfaces

      una vez que abra se debe colocar la configuración de estatica o dhcp depende la elección. aqui se las coloc las dos

      #######################################
      #Para configurar la interfaz de red en forma fija: #
      #######################################
      auto lo
      iface lo inet loopback
      auto eth0
      iface eth0 inet static
      address 192.168.XX.XX
      netmask 255.255.255.0
      network 192.168.XX.XX
      broadcast 192.168.XX.255
      gateway 192.168.XX.1

      ###############################################
      #Para configurar la interfaz de red en forma dinámica (por DHCP):#
      ###############################################
      auto lo
      iface lo inet loopback
      auto eth0
      iface eth0 inet dhcp

      -------------------------

      Eliminar
  4. hola kimberlin me podrias ayudar? segui todos los pasos al pie de la letra pero todavia me aparece este error. root@canaima-popular:/home/canaima# sudo dpkg -i /tmp/google-chrome-stable_current_amd64.deb
    dpkg: error al procesar /tmp/google-chrome-stable_current_amd64.deb (--install):
    no se puede acceder al archivo: No existe el fichero o el directorio
    Se encontraron errores al procesar:
    /tmp/google-chrome-stable_current_amd64.deb
    root@canaima-popular:/home/canaima#

    se descargo bien pero no me instala. tambien puse el ultimo comando pero no se soluciona. de antemano gracias

    ResponderEliminar
  5. nada!! no me funviono ninguna de tus explicaciones, los terminales no reconocen nada de esto, puedes ayudarme?

    ResponderEliminar
  6. Tengo un problema, me aparece este error
    dpkg: error al procesar google-chrome-stable (--install):
    problemas de dependencias - se deja sin configurar
    Procesando disparadores para desktop-file-utils ...
    Procesando disparadores para gnome-menus ...
    Procesando disparadores para man-db ...
    Procesando disparadores para menu ...
    Se encontraron errores al procesar:
    google-chrome-stable

    Segui todos los pasos y nada. Podrias ayudarme?

    ResponderEliminar
  7. me dice error al procesar google cuando lo voy a instalar que ago?

    ResponderEliminar
  8. me da estos rrores que deberia de hacer?
    google-chrome-stable:
    Depende: gconf-service but it is not installable
    Depende: libgconf-2-4 (>=2.31.1) but it is not installable
    Depende: libgdk-pixbuf2.0-0 (>=2.22.0) but it is not installable
    Depende: libglib2.0-0 (>=2.26.0) pero se va a instalar 2.24.2-1
    Depende: libgtk2.0-0 (>=2.24.0) pero se va a instalar 2.20.1-2
    Depende: libnspr4 pero no va a ser instalado
    Depende: libnss3 pero no va a ser instalado
    Depende: fonts-liberation but it is not installable
    Depende: libappindicator1 but it is not installabl

    ResponderEliminar
  9. buenas la canaima no me deja instalar el paquete libcurl3 hice el primer paso que pusiste y me sale

    root@canaima-popular:/home/canaima# aptitude install libcurl3 libxss1
    Se instalarán los siguiente paquetes NUEVOS:
    libcurl3
    Se ELIMINARÁN los siguientes paquetes:
    ca-certificates-java{u} chromium-browser-inspector{u} ffmpeg{u}
    ffmpeg2theora{u} flashplugin-nonfree{u} gstreamer0.10-fluendo-mp3{u}
    jclic{u} libaccess-bridge-java{u} libaccess-bridge-java-jni{u}
    libavdevice52{u} libavfilter1{u} libglewmx1.5{u} libv8-2.2.24{u}
    spawn-fcgi{u} sun-java6-plugin{u} tinyproxy{u}
    0 paquetes actualizados, 1 nuevos instalados, 16 para eliminar y 1 sin actualizar.
    Necesito descargar 281 kB de ficheros. Después de desempaquetar se liberarán 13,0 MB.
    ¿Quiere continuar? [Y/n/?]
    Err http://paquetes.canaima.softwarelibre.gob.ve/ auyantepui/main libcurl3 i386 7.21.0-2.1+squeeze2
    404 Not Found
    (Leyendo la base de datos ... 125187 ficheros o directorios instalados actualmente.)
    Desinstalando ca-certificates-java ...
    Desinstalando chromium-browser-inspector ...
    Desinstalando ffmpeg ...
    Desinstalando ffmpeg2theora ...
    Desinstalando flashplugin-nonfree ...
    Desinstalando gstreamer0.10-fluendo-mp3 ...
    Desinstalando jclic ...
    Desinstalando libaccess-bridge-java-jni ...
    Desinstalando libaccess-bridge-java ...
    Desinstalando libavdevice52 ...
    Desinstalando libavfilter1 ...
    Desinstalando libglewmx1.5 ...
    Desinstalando libv8-2.2.24 ...
    Desinstalando spawn-fcgi ...
    Desinstalando sun-java6-plugin ...
    Desinstalando tinyproxy ...
    Stopping tinyproxy: tinyproxy.
    Procesando disparadores para man-db ...
    Procesando disparadores para menu ...
    Procesando disparadores para desktop-file-utils ...
    Procesando disparadores para gnome-menus ...
    Procesando disparadores para readahead-fedora ...
    E: Se produjo un fallo al descargar http://paquetes.canaima.softwarelibre.gob.ve/pool/main/c/curl/libcurl3_7.21.0-2.1+squeeze2_i386.deb: 404 Not Found

    ResponderEliminar
  10. Hola Kimberling cuando trato de instalar Google Chrome en mi canaima del liceo me dice el siguiente error:Error: Arquitectura incorrecta 'amd64'
    ¿Que puedo hacer?

    ResponderEliminar
  11. como arreglo el error de "amd64" que me sale cuando intento actualizar google chrome?

    ResponderEliminar
  12. buenas tardes kimberling, era para saber si sabías como instalar programas de 32 bits en una canaima de 34?

    ResponderEliminar
  13. hola hice todo el proceso ya yo he descargado todas las versiones de google chrome y nada siempre me dice permiso denegado

    ResponderEliminar